Випуск установки Magento 2: помилка 404 під час спроби завантаження сторінки адміністратора


11

Я успішно встановив Magento 2 на сервері wamp, але у мене виникає невелика проблема завантаження сторінки адміністратора, оскільки він дає мені 404. Також при завантаженні його домашньої сторінки тема за замовчуванням, що є в моєму випадку, не застосовується і натомість дає мені такі помилки:

Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/mage/calendar.css     
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/styles-m.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/styles-l.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/print.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/images/logo.svg    
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/styles-m.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/styles-l.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/requirejs/require.js 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/print.css     
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/mage/requirejs/mixins.js 
Failed to load resource: the server responded with a status of 404 (Not Found)
requirejs-config.js:602 Uncaught ReferenceError: require is not defined
127.0.0.1/:24 Uncaught ReferenceError: require is not defined
127.0.0.1/:26 Uncaught ReferenceError: require is not defined

перевірити відповідь тут: magento.stackexchange.com/questions/91087/…
— Аніл Сутар

Відповіді:


18

Css та js будуть створені під час виконання роботи у папці pub / static. Перший час, якщо відсутні css та js, запустіть нижче команди

якщо ви використовуєте Windows: php bin\magento setup:static-content:deploy

якщо ви використовуєте linux 'git bash': php bin/magento setup:static-content:deploy


Також переконайтеся, що ви включили переписування сервера Apache
— Стів Джонсон

Будемо вдячні, якби ви могли розбити кроки. Як запустити команду Windows? Як дізнатися, чи справді це спрацювало?
— Мохаммед Джораїд

Нічого не варто, що якщо ви завантажили джерело з github і встановите через браузер, вам потрібно буде включити режим розробника. Наведена вище команда скаржиться на те, що вам не потрібно запускатись setup:static-content:deployу режимі розробника, тому переконайтесь, що ви додаєте -fдо вищевказаної команди. Якщо ви встановили іншу мову, ніж en_US, вам також потрібно буде надати такі:php bin\magento setup:static-content:deploy -f en_US en_GB
— BugHunterUK

13

Я також стикався з цією проблемою. Адміністратор видає помилку 404 і frontend не приєднав css (тобто Luma didnot показ у належному форматі ..), тому я зробив ці кроки, щоб вирішити ці обидві проблеми в magento 2. 1) перейдіть до терміналу і запустіть цю команду

sudo gedit /etc/apache2/apache2.conf

І зміни: -

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride none
Require all granted

До

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted

змініть лише AllowOverride нікому для всіх

і

2) перейти до терміналу і запустити команду: -

sudo a2enmod rewrite
sudo service apache2 restart

Потім дайте дозвіл вашому var, pub та додатку / тощо. а потім перейдіть до свого адміністратора і перегляньте, що він працює належним чином


1
Людина, я спробував 1000 рішень, але тільки цей працював на мене, дуже дякую!
— Васіф Халіл

8

Для тих, хто використовує сервер wamp, тоді запустіть ці команди у своєму CLI.

C: \ wamp \ bin \ php \ php5.5.12> php.exe
C: \ wamp \ www \\ bin \ magento setup: статичний контент: розгорнути


6

Я також стикався з цим питанням. Після свіжого встановлення magento 2 з демонстраційними даними під час навігації по фронту та заходу також у localhost. Отримав помилки типу MIME у невідповідності для Calendar.css та Requ.js. Ніщо не працювало для мене, якщо не розгорнути статичний контент наскрізь

php bin/magento setup:static-content:deploy

в git bash і поки це режим за замовчуванням.



2

Увімкнути перезапис URL-адрес.

1) Відкрийте термінал в Ubuntu та виконайте ці команди:

sudo a2enmod rewrite

sudo service apache2 restart

2) Переконайтеся, що ви маєте .htaccessфайл у вашому кореневому каталозі magento, якщо його немає. htaccessскопіюйте /pub/.htaccessфайл і вставте його в кореневу директорію

3) Відкрийте /etc/apache2/apache2.confфайл за допомогою наступних команд:

sudo nano /etc/apache2/apache2.conf

І змінити наступні рядки коду:

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride none
Require all granted

До

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted

Збережіть і закрийте файл Ctrl + X

  • Перезапустіть апаш

    перезапуск служби sudo служби apache2

Використовуючи наш веб-сайт, ви визнаєте, що прочитали та зрозуміли наші Політику щодо файлів cookie та Політику конфіденційності.
Licensed under cc by-sa 3.0 with attribution required.