Де я можу використовувати префікс документації IPv6


13

Наразі ми будуємо мережевий курс з практичною частиною, де студенти повинні налаштувати невелику мережу у віртуальному середовищі.

Однак ми не впевнені, які префікси ipv6 ми можемо використовувати для конфігурації. Префікс документації IPv6 ( 2001:db8::/32 RFC3849 ), здається, відповідає. Однак хтось придумав, що цей префікс слід використовувати лише в текстових прикладах і ніколи не бути налаштованим ніде, навіть в ізольованій тестовій мережі. (Звичайно, це спрацювало б, але це може розглядатися як порушення RFC).

Тут питання полягає в тому, що RFC щодо цього є досить абстрактним, і все залежить від того, як трактується термін "документація". Я не зміг знайти жодних джерел про використання в експериментальних тестових / навчальних мережах або специфікації "документації" в Інтернеті.

Ви можете мені допомогти?

Відповіді:


11

Якщо ваше тестове середовище відокремлено від локальної мережі, ви гіпотетично можете використовувати будь-які адреси IPv6, які не зарезервовані для спеціального використання. Однак якщо ви шукаєте еквівалент приватних IPv4-адрес, вам варто ознайомитися в RFC4193 .

Там ви бачите, що fc00::/7це підходяща підмережа для цілей тестування.

З іншого боку, ви, можливо, отримали від свого провайдера префікс IPv6, який ви можете розбити для своїх потреб.


Так, ми також розглядали fc00: / 7 (або точніше fd: 00/8) як варіант. Однак це означає, що нам потрібно використовувати 40 випадково створених бітів + ​​підмережі, щоб отримати префікс / 64 (згідно з RFC). Використання, наприклад, 0000 ... як "випадкового" числа буде порушувати RFC, використання реальних випадкових чисел зробить IPv6 адреси, ймовірно, дуже важко запам'ятати студентам, що також не бажано.
— sliebald

ULA не еквівалентно приватному адресуванню RFC 1918. При приватній адресації IPv4 передбачається, що кілька мереж будуть використовувати одну і ту ж адресацію, але ULA розроблена, щоб спробувати запобігти тому, щоб шанси двох мереж, що використовують одну і ту ж адресацію, дуже-дуже малі.
— Рон Моупін

Я б також радив використовувати один або кілька префіксів відповідно до RFC4193 від fd :: / 8. У реальному житті студенти також не зустрінуться / 48-ті, які легко запам'ятовуються.
— Marc 'netztier' Luethi

Це правда, проте існує багато префіксів fX ... / 64, які є спеціальними в IPv6, тому вони теж не допомагають у цій проблемі.
— sliebald

Шанси будь-якої певної пари мереж, які використовують одні і ті ж адреси, дуже малі, але шанси на те, що вони є двома мережами у світі з тим самим префіксом ULA, насправді дуже великі.
— Пітер Грін

19

Префікс документації IPv6 (2001:db8:::/32)повинен використовуватися ТІЛЬКИ для цілей документації. Це означає письмові приклади, схеми, презентації PPT, пояснення підручника тощо.

Цей діапазон не слід використовувати в практичних мережах.

Існує "приватний діапазон IP", fc00::/7який слід використовувати для тестування пристроїв, демонстрацій, курсів тощо відповідно до RFC4193

Адреси в одній смузі повинні використовуватися в локальних мережах без доступу до загальнодоступного Інтернету.


Що стосується fc00: / 7, дивіться мій коментар до Саша Р. У нас всередині також деякі люди стверджують, що мережа, яку ми використовуємо, також може розглядатися як документація (або, принаймні, вона використовується як практична частина документації / пояснення IPv6 до студенти). Тільки з RFC я не бачу нічого, що визначає, що документація є строго написаним текстом. Чи є у вас джерела для цієї інтерпретації?
— sliebald

@StefanLiebald В APNIC вони заявляють, щоThe documentation prefix is the IPv6 address range that has been set aside for this purpose.
— jcbermu

@ jcbermu Ей, вони також заявляють: "У технічних книгах, статтях та навчальних матеріалах часто потрібно показувати приклади використовуваних IP-адрес." З моєї точки зору, "навчальний матеріал" цілком би відповідав тому, що ми плануємо робити. Тренінг для мене включає практичні вправи (або навіть їх можна вважати синонімами).
— sliebald

8

Тільки з RFC я не бачу нічого, що визначає, що документація є строго написаним текстом. Чи є у вас джерела для цієї інтерпретації?

Відповідно до реєстру адрес спеціального призначення IANA IPv6 , 2001:db8::/32діапазон адрес документації не може використовуватися в адресах джерела чи призначення, не є перешкодним (маршрутизованим), а також глобально доступним і не зарезервований жодним протоколом. Це робить діапазон адрес непридатним для використання у фактичній мережі.

Як, наприклад, ви б використовували будь-які адреси в цьому діапазоні, якщо їм не дозволяється використовувати як вихідні або цільові адреси в IP-пакетах?

Насправді ви можете працювати на деяких пристроях, які просто відмовляються використовувати цей діапазон адрес, і це було б цілком у межах стандартів. Зрештою, IANA володіє всіма адресами IPv4 та IPv6.


Nitpicking: afaik, IANA не володіє застарілими мережами IPv4, виділеними Центральним Інтернет-реєстром до існування.
— JFL

4
@JFL, IANA робить, саме так ми закінчилися з 172.16.0.0/12діапазоном приватних адрес. IANA попросила юридичну фірму, що "володіє" діапазоном адрес для деяких із них для приватного адресації. Юридична фірма відмовилася, тому IANA її просто взяла. У результаті судового позову встановлено, що IANA фактично володіє всіма IP-адресами
— Рон Моупін
Використовуючи наш веб-сайт, ви визнаєте, що прочитали та зрозуміли наші Політику щодо файлів cookie та Політику конфіденційності.
Licensed under cc by-sa 3.0 with attribution required.