Чому 192.168. *. * Для місцевих адрес? [зачинено]


34

Я вже бачив стандарт використання 192.168. *. * IP-адрес для пристроїв у локальній мережі.

Чому саме таке поєднання? Якби я був, я вибрав би щось простіше, наприклад 1.0. *. *. Яка історична причина?


5
10.0.0.0/8 є дійсним приватним адресним простором ... це досить просто
— Майк Пеннінгтон

5
192Частина майже напевно виходить з того , що це був приватне використання блок , пов'язаний з C IP - адреси класу (ще на початку, дні) класових і клас C почався в 192.0.0.0. Докладніше на тему Чому для домашніх мереж встановлено префікс 192.168? (Супер користувач) і чому 192.168.xy використовується для локальних IP-адрес? (Переповнення стека), але я не можу знайти обґрунтування вибору в 168будь-якій точці Інтернету.
— Попс

4
@pops, найкраще, що я знайшов, це повідомлення від Стівена Ербара , який стверджував, що 192.168. *. * використовувалося системою в керівництві; це призвело до значної кількості людей, які використовують цей адресний простір у своїх внутрішніх мережах. Це звучало досить знайомо, що Ренді Буш подумав, що це Сонце (але це не було)
— Майк Пеннінгтон

Питання про історичні дрібниці тут явно поза темою.
— Рон Моупін

Відповіді:


34

Примітка: Якщо ми не зможемо коментувати одного з оригінальних авторів RFC 1918 / RFC 1597 або когось із InterNIC / RIPE NCC в той час (1994-1996) *, ми можемо залишитись на здогадки та відповіді на це питання. будучи переважно на думці.


На RFC 1918 наступні три діапазони зарезервовані для використання в приватних мережах:

10.0.0.0        -   10.255.255.255  (10/8 prefix)
172.16.0.0      -   172.31.255.255  (172.16/12 prefix)
192.168.0.0     -   192.168.255.255 (192.168/16 prefix)

Ось чому ви бачите їх використовувати для пристроїв у локальній мережі.

Міркування щодо принаймні частин кожного з цих трьох "приватних" діапазонів адрес є досить простим, але, знову ж таки, поза логікою, це здогадки, що ґрунтуються на моїх показаннях протягом багатьох років.

Спочатку врахуйте, що класичні мережі такі (джерела статті Вікіпедії про Класифіковану мережу ):

Class A
  0.  0.  0.  0 = 00000000.00000000.00000000.00000000
127.255.255.255 = 01111111.11111111.11111111.11111111
                  0nnnnnnn.HHHHHHHH.HHHHHHHH.HHHHHHHH

Class B
128.  0.  0.  0 = 10000000.00000000.00000000.00000000
191.255.255.255 = 10111111.11111111.11111111.11111111
                  10nnnnnn.nnnnnnnn.HHHHHHHH.HHHHHHHH

Class C
192.  0.  0.  0 = 11000000.00000000.00000000.00000000
223.255.255.255 = 11011111.11111111.11111111.11111111
                  110nnnnn.nnnnnnnn.nnnnnnnn.HHHHHHHH

Class D
224.  0.  0.  0 = 11100000.00000000.00000000.00000000
239.255.255.255 = 11101111.11111111.11111111.11111111
                  1110XXXX.XXXXXXXX.XXXXXXXX.XXXXXXXX

Class E
240.  0.  0.  0 = 11110000.00000000.00000000.00000000
255.255.255.255 = 11111111.11111111.11111111.11111111
                  1111XXXX.XXXXXXXX.XXXXXXXX.XXXXXXXX

Як бачимо, кожен з трьох діапазонів RFC1918 вирізає приватний блок із одного зі старих діапазонів «класних» мереж. (Клас А, Клас В та Клас С у цьому випадку.)

Цитуючи Дамблдора, "З цього моменту ми залишатимемо міцний фундамент факту і разом мандруємо через мутні болота пам'яті в зарості найсміливіших здогадок".

IANA був призначення адрес в протягом багатьох років до створення RFC 1918 (лютий 1996) . (Насправді приватні діапазони були вперше викладені в RFC 1597 в березні 1994 р.) Наприклад, якщо ви провадите whois 8.0.0.0пошук, ви можете бачити, що рівень 3 цього блоку був призначений 1992-12-01.

Тому можна припустити, що авторам RFC1918 довелося співпрацювати з IANA / Jon Postel, щоб знайти доступні діапазони, надавши нам приватні діапазони, перелічені вище.

Але знову ж таки, якщо хтось, безпосередньо пов'язаний з процесом *, не заговорить, це може залишатися здогадками.

* Або просто хтось із кращою програмою Google, ніж я. Мені не вдалося знайти хорошого основного джерела для цієї інформації.


1
Це вірно. У той час використовували скляні адреси. Для розміщення мереж різного розміру були призначені мережі одного класу А, 32 класу В та 256 класів С. Чому 10, 172.16 та 192.168? Тому що це була думка і такі були доступні.
— Багамат

4
@bahamat 192.168.1.0/24 і 10.1.1.0/24 порівнянні. Обидві підмережі вписуються в однакову структуру C ... пам'ять не збережено за 192.168
— Майк Пеннінгтон

2
CIDR близько 20 років, 20 років тому ніхто не мав домашніх маршрутизаторів
— Майк Пеннінгтон

2
@bahamat, у 9 разів з 10 домашніх маршрутизаторів нульова потреба запускати IGP (класний чи ні), і області DHCP на них повністю настроюються користувачем, тому я не бачу обгрунтованості вашого твердження.
— Джон Дженсен

2
10/8 був старий ARPANET. Після того, як простір повернувся до ARIN, він був відзначений зарезервованим і став першим / 8, наскільки я знаю, доступним для приватного використання. 172.16 / 12 мали найбільше безперервне виділення без призначення. Не впевнений у 192.168 / 16, крім того, що був доступний у старому асортименті класу C.
— generalnetworkerror

5

Як вказували інші, RFC1918 визначає 3 приватні діапазони IP. У 1996 році все ще існувало застаріле обладнання, яке не підтримувало CIDR , тому для кожного класу був створений один діапазон. Адреси класу В починаються з 128.0.0.0, а адреси класу С починаються з 192.0.0.0; 168 було обрано лише тому, що воно було нерозподілене.

Але це викликає ще одне питання - чому потрібен був діапазон класу С? Оскільки єдиною різницею класів A, B і C є розмір мережі, чому б просто не використовувати 10.0.0.0/8? Відповідно до RFC1918:

Якщо відповідна схема підмережі може бути розроблена та підтримується відповідним обладнанням, доцільно використовувати 24-бітний блок (мережа класу A) приватного адресного простору та скласти план адресації з хорошим шляхом зростання. Якщо підмережа є проблемою, можна використовувати 16-бітний блок (мережі класу С) або 20-бітний блок (мережі класу В) приватного адресного простору.

Я точно не впевнений, про які «проблеми» з підмережею думали автори. Можливо, деяке обладнання до-CIDR не підтримувало мережі класу A через обмеження пам’яті (хоча, на вашу думку, це має значення кількість хостів, а не кількість потенційних хостів).

Крім того, мережі класу С / 24, хоча 192.168.xx - це / 16 - значить, в класових мережах 192.168.xx насправді містить 256 підмереж. Це може бути корисним для великих організацій, які хотіли запускати приватні підмережі на апаратному забезпеченні до CIDR.


гм a / 24 може бути мережею класу C, якщо перші біти адреси є 110. Але ви також отримуєте / 24 з мережі класу A або B. Класна мережа давно мертва. Слід використовувати лише клас-A, -B, -C в історичному контексті.
— Jens Link

-1

Будь ласка, використовуйте 10.0.0.0 - 10.255.255.255, на RFC 6890 , сторінка 6.

Раніше я вважав, що відповідати на історичні питання - це гарна ідея, але я хотів би уникати цього робити регулярно через поганий досвід вампірів. У цьому випадку це не здається необхідним. 10.0.0.0/8 досить простий.


1
Відверто кажучи, ви не відповідаєте на питання. Я запитую про історію цього, а не для більш простого локального діапазону. Якщо ви не вважаєте, що це гарне питання, закрийте його.
— Скасувати

1
Передумовою, що стоїть проти Вашого заперечення проти 192.168. *. *, Є те, що Ви б вибрали щось простіше. Справа в тому, що 10.0.0.0/8 - це також простір RFC1918, і це щось простіше, але ви не можете випадково вирішити вибрати будь-який адресний простір в Інтернеті без ускладнень . Якщо громада хоче закрити це добре ... Підсумовуючи, я думаю, ви надмірно педантичні WRT "Не кажи мені про 10.0.0.0/8, тому що я запитав про 192.168 місця".
— Майк Пеннінгтон

2
Я вас повністю поважаю, і не хочу звучати інакше. Однак, схоже, відповісти на питання "Я б краще не відповів на це так, як зараз, тому ось відповідь на дуже пов'язане питання" не зовсім правильно. Я більше шукаю мотивацію, що стоїть за нею, не обов'язково історію як такої. Дякуємо, що відкриті для обговорення!
— Скасувати

Використовуючи наш веб-сайт, ви визнаєте, що прочитали та зрозуміли наші Політику щодо файлів cookie та Політику конфіденційності.
Licensed under cc by-sa 3.0 with attribution required.