Як налаштувати Amazon Route53, що працює без www у піддомені


13

редагувати: Amazon тепер підтримує це. http://aws.typepad.com/aws/2012/12/root-domain-website-hosting-for-amazon-s3.html

У мене конфігурація домену в Route53 на Amazon AWS

команда exec ping в моєму домені без www

$ ping mydomain.com.br
ping: cannot resolve domain.com.br: Unknown host

команда exec ping у моєму домені за допомогою www

$ ping www.domain.com.br
PING s3-website-sa-east-1.amazonaws.com (177.72.245.6): 56 data bytes
64 bytes from 177.72.245.6: icmp_seq=0 ttl=244 time=25.027 ms
64 bytes from 177.72.245.6: icmp_seq=1 ttl=244 time=25.238 ms
64 bytes from 177.72.245.6: icmp_seq=2 ttl=244 time=25.024 ms

Маршрут 53 -> Створити набір записів -> Ім'я: [] .domain.com.br Встановити значення CNAME: www.domain.com.br

Помилка дисплея

"RRSet типу CNAME з іменем DNS mydomin.com заборонено на вершині apex у зоні mydomin.com"


1
Привіт, зауважте, що відповіді повинні міститись у розділі "Відповіді" нижче, а не як редагування запитання.
— Майкл Хемптон

Відповіді:


6

Ви не можете використовувати CNAME для домену кореневого рівня, він порушує RFC і може спричинити ряд проблем. На жаль, Amazon не має вирішення для веб-сайтів, розміщених S3.

редагувати: Amazon тепер підтримує це. http://aws.typepad.com/aws/2012/12/root-domain-website-hosting-for-amazon-s3.html

Є такі сервіси, як WWWizer, які можна використовувати для переадресації на WWW, але вони не є ідеальним рішенням.


2
Ви можете використовувати CNAME з доменами кореневого рівня, що не порушує RFC. Проблема полягає в тому, що CNAME не може співіснувати з іншими записами, наприклад, MX. Від RFC1034 ...... Якщо CNRE RR присутній у вузлі, інших даних не повинно бути; це гарантує, що дані для канонічного імені та його псевдонімів не можуть бути різними. Це правило також гарантує, що кешований CNAME можна використовувати без перевірки на авторитетному сервері для інших типів RR.
— Джеймс Парк-Ватт

@ JamesPark-Watt blog.cloudflare.com/… "Проблема полягає в тому, що DNS RFC (RFC1033) вимагає, щоб" зона вершини "(іноді її називають" кореневим доменом "або" голим доменом ") була" Записом ", а не CNAME. "
— ceejayoz

Ідеально -> посилання Root Domain хостинг веб-сайтів для Amazon S3
— romuloigor

1
Apex CNAME не є законними. Це було чітко прописано в RFC2181 деякий час.
— Андрій Б

5

Створіть набір записів ресурсів (тип A - IPv4 адреса), який "має те саме ім'я, що і розміщена зона, залишаючи поле Ім'я порожнім".

Amazon Route 53 - редагування набору записів

Це попередження, яке Маршрут 53 дає при спробі додати ім'я "@", яке я також використовував для серверів імен Прив'язувати. Тому не використовуйте "@", використовуйте порожнє ім'я "".


1
А тепер використовуючи @твори для запису A, щоб отримати голий домен.
— Рубенс Маріуццо

1

Якщо ви хочете вказати кореневий домен mydomain.com.br на сервіс від AWS:

  • створити запис типу A - IPv4 Address .
  • потім виберіть Так для псевдоніму.
  • Псевдонім Target перерахує автоматичне заповнення ваших ресурсів AWS.
Використовуючи наш веб-сайт, ви визнаєте, що прочитали та зрозуміли наші Політику щодо файлів cookie та Політику конфіденційності.
Licensed under cc by-sa 3.0 with attribution required.