VirtualBox: випуск із символьними посиланнями у спільних папках [закрито]


14

Деякий час тому з'явилася нитка, щоб точно встановити ту саму проблему: Неможливо створити посилання у папках, що діляться у virtualbox . Зараз це закрито (чому?). Тож я починаю нове, бо зараз у мене виникла ця проблема і не можу знайти рішення.

Короткий опис випуску: Atpms для створення / розміщення символьної посилання у загальній папці виникає помилка:

root@devmv:/var/www/sandbox/zf1sandbox# ln -s /lib/ZendFramework/ZF1 ZF1
ln: creating symbolic link `ZF1': Protocol error

Я вже намагався різними способами активувати посилання на свою робочу область в спільній папці:

C:\Windows\system32>VBoxManage setextradata "Dev VM" VBoxInternal2/SharedFoldersEnableSymlinksCreate/var/www 1
C:\Windows\system32>VBoxManage setextradata "Dev VM" VBoxInternal2/SharedFoldersEnableSymlinksCreate/var/www/ 1
C:\Windows\system32>VBoxManage setextradata "Dev VM" VBoxInternal2/SharedFoldersEnableSymlinksCreate/workspace 1
C:\Windows\system32>VBoxManage setextradata "Dev VM" VBoxInternal2/SharedFoldersEnableSymlinksCreate/workspace/ 1
C:\Windows\system32>VBoxManage setextradata "Dev VM" VBoxInternal2/SharedFoldersEnableSymlinksCreate/M:\workspace 1
C:\Windows\system32>VBoxManage setextradata "Dev VM" VBoxInternal2/SharedFoldersEnableSymlinksCreate/M:\workspace\ 1

Я не отримую помилок на кшталт

C:\Windows\system32>VBoxManage setextradata devvm VBoxInternal2/SharedFoldersEnableSymlinksCreate/workspace 1
VBoxManage.exe: error: Failed to create the VirtualBox object!
VBoxManage.exe: error: Code CO_E_SERVER_EXEC_FAILURE (0x80080005) - Server execution failed (extended info not available)
VBoxManage.exe: error: Most likely, the VirtualBox COM server is not running or failed to start.
C:\Windows\system32>VBoxManage setextradata "Dev VM" VBoxInternal2/SharedFoldersEnableSymlinksCreate/workspace 1
VBoxManage.exe: error: Failed to create the VirtualBox object!
VBoxManage.exe: error: Code CO_E_SERVER_EXEC_FAILURE (0x80080005) - Server execution failed (extended info not available)
VBoxManage.exe: error: Most likely, the VirtualBox COM server is not running or failed to start.

але це все ще не працює.

Я також встановив розширення Oracle VM VirtualBox Pack (можна завантажити тут ). Але працювати просто не хочеться.

Було б чудово, якби хтось міг допомогти.

Дякую

System parameter:
Host: Winwows 7 64Bit
Guest: Debian 6.0.6 64Bit
VirtualBox: 4.2.6

Редагувати:

Деякі додаткові відомості:

C:\Windows\system32>VBoxManage getextradata "Dev VM" enumerate
Key: GUI/LastCloseAction, Value: shutdown
Key: GUI/LastGuestSizeHint, Value: 720,400
Key: GUI/LastNormalWindowPosition, Value: 390,158,1424,819,max
Key: GUI/LastScaleWindowPosition, Value: 640,345,640,480,max
Key: GUI/MiniToolBarAlignment, Value: bottom
Key: GUI/SaveMountedAtRuntime, Value: yes
Key: GUI/ShowMiniToolBar, Value: yes
Key: VBoxInternal2/SharedFoldersEnableSymlinksCreate/M:\workspace, Value: 1
Key: VBoxInternal2/SharedFoldersEnableSymlinksCreate/M:\workspace\, Value: 1
Key: VBoxInternal2/SharedFoldersEnableSymlinksCreate/var/www, Value: 1
Key: VBoxInternal2/SharedFoldersEnableSymlinksCreate/var/www/, Value: 1
Key: VBoxInternal2/SharedFoldersEnableSymlinksCreate/workspace, Value: 1
Key: VBoxInternal2/SharedFoldersEnableSymlinksCreate/workspace/, Value: 1

Отже, зміни конфігурації збережено. Але вони не працюють.


7
Чотири голоси та жоден коментар. Чому це питання було скасовано? Я міг би це вдосконалити, але спершу маю знати, що з цим погано.
— automatix

1
Я погоджуюсь, що вона належить тут, тому тут йде моє оновлення
— Brick

Для мене роботи адміністратора було недостатньо, і я все ж отримав "Протокольну помилку" при спробі створення символьних посилань. Ось що працювало: stackoverflow.com/a/60741351/470749
— Ryan

Відповіді:


20

Це працює!

У Windows за замовчуванням лише адміністратори можуть створювати посилання. Коли я запускаю VirtualBox як адміністратор, я можу створювати символьні посилання без проблем.

Для того, щоб мати можливість створювати посилання без запуску VB як адміністратора, вам потрібно встановити цей дозвіл для вашого користувача / групи користувачів. Ось короткий підказки.

Єдина проблема - я не знайшов способу дозволити створення символьних посилань адміністраторам-користувачам. Я не знаю, чи це можливо.


1
Навіть дозволяючи групі "Усі" в політиці, я не зміг цього досягти, не запустивши машину як адміністратор. Запуск vagrant upз адміністративної консолі вирішив мою проблему.
— Marco Aurélio Deleu

2

З документації :

Починаючи з версії 4.0, спільні папки VirtualBox також підтримують символічні посилання (символьні посилання) за таких умов:

  1. Хост-операційна система повинна підтримувати символьні посилання (тобто потрібен хост Mac, Linux або Solaris).
  2. Наразі лише Linux та Solaris Guest Additions підтримують символьні посилання.

Оскільки вашим хостом є Windows, символьні посилання не підтримуються.


Дякую за відповідь, але "Windows 7 та Windows Vista підтримують символічні посилання як на файли, так і на каталоги" ( Вікіпедія ).
— automatix

@automatix У документації зазначено, що підтримуються лише хости Mac, Linux та Solaris, тому я думаю, що він не був реалізований для Windows.
— mgorven

Документація тільки говорить, що ОС необхідно, який підтримує символічні посилання (наприклад , Mac, Linux, Solaris ...). Windows підтримує символьні посилання. Символьні посилання Ergo повинні працювати на хостах Windows. Чи можете ви опублікувати посилання, де ви прочитали, що Windows не підтримується.
— automatix

Емуляція посилань Posix під Windows розглядає, як символічні посилання відрізняються у двох операційних системах. TL; DR: вони реалізовані по-різному в Windows і не інтерпретуються як посилання на ОС, сумісні з Posix.
— cr0m

1
Символьні посилання підтримуються в Windows, але вам потрібно запуститись як адміністратор, щоб мати можливість їх створювати
— Immutable Brick

0

На хості Linux у мене була схожа проблема. Що я зробив, це зробити симпосилання в загальній папці на хості, але вказуючи на папку гостя. Потім гість підхопив це і побіг цілком радісно. Ймовірно, потрібно розібратися, чому я не можу це зробити безпосередньо від гостя в якийсь момент, але це зручне швидке виправлення.

наприклад:

(хост:) / var / www / mysharedfolder # ln -s (гість:) / var / www / mylinkedfolder myfolder

Використовуючи наш веб-сайт, ви визнаєте, що прочитали та зрозуміли наші Політику щодо файлів cookie та Політику конфіденційності.
Licensed under cc by-sa 3.0 with attribution required.